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Chapter 12
2D Plots

To visualize a function of one variable, an expression of one variab
paired data, or a vector, you can create an X-Y plot or a polar plot.

The following sections describe the use of these plots:

Overview of 2D plotting
Introduction to creating X-Y and polar plots.

Graphing functions and expressions
Procedures for graphing a function or expression or one function or expres
against another. Multiple traces on a single plot.

Graphing vectors and data
Procedures for graphing a single vector or one vector against another. 

Formatting a 2D plot
Procedures for modifying and setting the default formats of axes and tra
in an X-Y or polar plot. Adding a title, axis labels, and other labels.

Modifying your 2D plot’s perspective 
Zooming in on a portion of a plot, and finding coordinates.
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Overview of 2D plotting

To visually represent a function or expression of a single variable or X-Y data in 
Mathcad, you can create an X-Y plot. Or, to plot functions, expressions, or data 
don’t lend themselves well to Cartesian (X-Y) coordinates, you can create a polar
While a typical X-Y plot shows a horizontal value x versus a vertical value y, a typical 
polar plot shows the value of a radial expression r versus an angular expression θ. See 
Figure 12-1 for examples.

For example, to create an X-Y plot:

■ Click in your worksheet wherever you want the graph to appear. 

■ Choose Graph⇒X-Y Plot  from the Insert menu 

or click  on the Graph toolbar. Alternatively, 
type @. Mathcad inserts a blank X-Y plot.

■ Fill in the placeholders on the bottom (x-axis) and 
on the left (y-axis) with a function, expression, or 
variable. 

■ Enter the axis limits if you want to specify them 
in the placeholders that appear on the axes. Or leave these placeholders emp
Mathcad automatically chooses limits. 

■ Click outside the plot or press [Enter] .

Mathcad creates the plot over a default range using default format settings. See
“Formatting a 2D plot” on page 245 for information on specifying a range. See 
“Formatting a 2D plot” on page 245 to change the format of a plot.

Tip To create an X-Y QuickPlot of an expression, enter an expression of one variable and then c

 on the Graph toolbar. Mathcad automatically creates an X-Y plot of that expression o
default range of values of the variable on the x-axis. See page 238. 

To resize a plot, click in the plot to select it. Then move the cursor to a handle al
the edge of the plot until the cursor changes to a double-headed arrow. Hold the m
button down and drag the mouse in the direction that you want the plot’s dimensio
change.
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Figure 12-1: Examples of 2D plots.

Note If a point is complex or invalid, Mathcad does not graph it. To graph the real or imaginary
of a point or expression, use the Re and Im functions to extract the real and imaginary parts, 
respectively. 

When you create a polar plot by choosing 
Graph⇒Polar Plot from the Insert menu or 

clicking  on the Graph toolbar, Mathcad inserts 
a blank polar plot.

You fill in the placeholders on the bottom (angular 
axis) and on the left (radial axis) with a function, 
expression, or variable. Click outside the plot or press 
[Enter]  to see the plot.

Note If some points in a function or expression are valid and others are not, Mathcad plots only
valid ones. If the points are not contiguous, Mathcad does not connect them with a line. You
therefore see a blank plot if none of the points are contiguous. To see the points, format th
to have symbols. See “Formatting a 2D plot” on page 245 for information on formatting tra

The remaining sections in this chapter focus on plotting functions, expressions, a
data. Although the pictures associated with the instructions typically show X-Y pl
the instructions apply to polar plots as well. 
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Graphing functions and expression s

When plotting a single Mathcad expression or function, you can create either an
plot or a polar plot. For example, to create an X-Y plot of a single expression or func

■ Click in your worksheet wherever you want 
the graph to appear. 

■ Enter the expression or function of a single 
variable you want to plot. Make sure the 
editing lines remain in the expression. 

■ Choose Graph⇒X-Y Plot  from the Insert

menu or click  on the Graph toolbar.

■ Press [Enter ] or click outside the graph. 

Mathcad automatically produces a plot over a 
default range of the independent variable: 
–10 to 10. A plot such as this, where Mathcad 
automatically chooses the range for the indepen-
dent variable, is called a QuickPlot.

If you don’t want Mathcad to use a default range for the plot, you can define the 
independent variable as a range variable before creating the plot. For example:

■ Define a range variable, such as x, that takes 
on the values you want to graph. (The range 
variable need not be called x; you can use any 
valid name.) See “Range variables” on page 125.

■ Enter the expression or function of a single 
variable you want to plot. Make sure the 
editing lines remain in the expression. 

■ Choose Graph⇒X-Y Plot  from the Insert 

menu or click  on the Graph toolbar.

■ Press [Enter ] or click outside the graph. 

Mathcad graphs one point for every value of the 
range variable, and, unless you specify other-
wise, connects each pair of points with a straight 
line.
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Tip To override Mathcad’s choices for the axis limits on a plot, click on the limits in the plot and 
the placeholders. See “Setting axis limits” on page 245 for more information.

 Multiple traces 

You can graph several traces on the same X-Y or polar plot. A graph can show se
y-axis (or radial) expressions against the same x-axis (or angular) expression. Or it can
match up several y-axis (or radial) expressions with a single corresponding x-axis (or 
angular) expression. 

To graph more than one function or expression on an X-Y plot, for example:

■ Enter the expressions or functions of a 
single variable you want to plot, separat-
ed by commas. Make sure the editing 
lines remain in the expression.

■ Choose Graph⇒X-Y Plot  from the

Insert menu or click  on the Graph 
toolbar.

■ Press [Enter ] or click outside the 
graph.

Mathcad produces a QuickPlot of all the expressions or functions, over a range o
to 10 for the variable on the x-axis. You can change the axis range by editing the upp
and lower limits on the x-axis as described in “Setting axis limits” on page 245.

Figure 12-2: Graph with multiple y-axis expressions.
Graphing functions and expressions 239
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To graph several independent curves on the same set of axes:

■ Choose Graph⇒X-Y Plot from the Insert menu or click  on the Graph toolbar

■ Enter two or more expressions separated by commas on the y-axis.

■ Enter the same number of expressions separated by commas on the x-axis. 

Mathcad matches up the expressions in pairs—the first x-axis expression with first y-
axis expression, the second with the second, and so on. It then draws a trace fo
pair. Each matching pair of expressions should use the same range variable. How
the range variable for one pair need not match the range variables for the other p
Figure 12-3 shows an example.

Note All traces on a graph share the same axis limits. For each axis, all expressions and limits o
axis must have compatible units.

Figure 12-3: Graph with multiple expressions on both axes.

Graphing one function or expression against another

You can graph one function or expression against another in either an X-Y plot o
polar plot. The expressions must refer to the same independent variable. For exa

■ Click in your worksheet wherever you want the graph to appear. 

■ Choose Graph⇒X-Y Plot  from the Insert menu or click  on the Graph toolbar
Mathcad inserts a blank X-Y plot with empty placeholders.

■ In the placeholder on the bottom, enter the function or expression to plot aga

■ In the placeholder on the left, enter the function or expression to plot.
240  Chapter 12  2D Plots
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■ Enter the axis limits in the remaining placeholders, if you want to specify them
you do not specify the limits, Mathcad automatically chooses limits for you. 

■ Click away from the plot or press [Enter] .

Mathcad automatically produces a QuickPlot over a default range of the indepen
variable. The first graph in Figure 12-1 shows an example.

If you don’t want Mathcad to use a default range for the plot, first define the indepen
variable as a range variable before creating the plot. Mathcad graphs one point fo
value of the independent variable and connects each pair of points with a straigh
Figure 12-4 shows two functions of θ plotted against each other. The range variableθ 
was previously defined. For information, see “Range variables” on page 125.

Figure 12-4: Graphing one function against another.

Graphing vectors and data

To graph the elements of a vector, you can create either an X-Y plot or a polar p
When creating either type, you need to use the vector subscript operator (see “V
and matrix operators” on page 154) to specify which elements to plot. Some grap
vectors are shown in Figure 12-5.

To graph a vector on an X-Y plot, for example:

■ Define a range variable such as i that references the subscript of each element o
the vector you want to plot. 

■ Click in your worksheet wherever you want the graph to appear. 
Graphing vectors and data 241
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■ Choose Graph⇒X-Y Plot  from the Insert menu or click  on the Graph toolbar
Mathcad inserts a blank X-Y plot.

■ Place i in the bottom placeholder and place the vector name together with the
subscript (  for example) in the placeholder on the left. Type [  as a shortcut to 
create the subscript.

■ Press [Enter ] or click outside the graph to see the result.

Figure 12-5: Graphing a vector.

Note Subscripts must be non-negative integers (or integers greater than or equal to ORIGIN, if
ORIGIN≠0). Τhis means that the x-axis or angular variable used in the graphs in Figure 12-
can run through whole-number values only. If you want to graph fractional or negative va
on the x-axis, graph a function or graph one vector against another, as described in the 
next section.

Tip If you have a handful of data points, you can use an input table to create a vector as shown
second graph in Figure 12-5. For more information, see “Entering data into a table” on pag

Graphing one vector against another 

To graph all the elements of one vector against all the elements in another, ente
names of the vectors in the axis placeholders on the X-Y plot or polar plot opera
For example, to create an X-Y plot of two vectors x and y, do the following:

■ Define the vectors x and y.

■ Click in your worksheet wherever you want the graph to appear. 

yi
242  Chapter 12  2D Plots
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■ Choose Graph⇒X-Y Plot  from the Insert menu, or click  on the Graph 
toolbar. Mathcad inserts a blank graph with empty placeholders.

■ Place  in the placeholder on the y-axis and  in the placeholder of the x-axis.

■ Press [Enter ] or click outside the graph to see the result.

Mathcad plots all the elements in the vector x against the elements in the vector y. 

Figure 12-6: Graphing two vectors.

Note If the vectors being plotted are not the same length, Mathcad plots the number of elements
shorter vector.

If you want to plot only certain vector elements, define a range variable and use it
subscript on the vector names. For instance, in the example outlined above, you 
plot only the fifth through tenth elements of x and y against each other. To do so:

■ Define a range variable such as k going from 4 to 9 in increments of 1. (Note tha
the first elements of the vectors x and y are  and  by default.) 

■ Enter  and  in the axis placeholders. 

Note The range variable on a vector must have integer values. However, Figure 12-7 shows how y
can calculate vectors in terms of other vectors of equally spaced non-integer values.

y x

x0 y0

yk xk
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Figure 12-7: Two vectors computed independently.

Graphing data

To plot a set of data in Mathcad, you simply plot vectors containing the data:

■ If you have one set of data values to graph, first create a vector by reading in
from a data file, by pasting in the data from the Clipboard, or by typing data dire
into an input table. See Chapter 11, “Vectors, Matrices, and Data Arrays.” Th
plot the vector as described in “Graphing vectors and data” on page 241.

■ If you want to graph one set of values against another set, you can create one 
for each set of data. Then plot one vector against the other as described in “Gra
one vector against another” on page 242.

Figure 12-8 shows an example of plotting vectors generated from data imported 
an external file with the READPRN function.

Figure 12-8: Plotting vectors from imported data.
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Formatting a 2D plot 

When you create an X-Y plot or a polar plot, Mathcad uses the default settings to fo
the axes and traces. You can, however, reformat a plot’s axes and traces. You ca
add titles and labels and control the default plot settings. 

To format a 2D plot:

■ Double-click the plot. Alternatively, 
click once on the plot and choose 
Graph⇒X-Y Plot  or Graph⇒Polar 
Plot from the Format menu. You’ll 
see the dialog box for formatting a 
selected plot. 

■ Click the tab for the page you want to 
work with. Use the Axes tab to deter-
mine the appearance of the axes and 
grid lines. Use the Traces tab to set the 
color, type, and width of the traces. Use 
the Labels tab to insert labels on the 
axes. Use the Defaults tab to specify 
the default appearance of plots.

■ Make the appropriate changes in the dialog box. 

■ Click “Apply” to see the effect of your changes without closing the dialog box. 

■ Close the dialog by clicking “OK.” 

Note In the Axes page, make sure you turn options on and off in the appropriate axis column. I
Traces page, click on a trace’s name in the Legend Label column and change characteris
clicking on the arrow beside each of the drop-down options.

Tip If you double-click an axis on a plot, you’ll see a formatting dialog box for that axis alone.

On-line Help Click “Help” in the dialog box for details on particular formatting options.

Setting axis limits

When you create a 2D plot, the Autoscale option is turned on. Use the Axes pag
the plot formatting dialog box to turn Autoscale on or off:
Formatting a 2D plot 245
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■ With Autoscale on, Mathcad automatically sets each axis limit to the first maj
tick mark beyond the end of the data. This is a reasonably round number larg
enough to display every point being graphed. 

■ With Autoscale off, Mathcad automatically sets the axis limits exactly at the 
data limits. 

Specifying other limits

You can override Mathcad’s automatic limits by entering limits directly on the gra
To do so:

■ Click the graph to select it. Mathcad displays four additional numbers, one by e
axis limit. These numbers are enclosed within corner symbols, as illustrated in
selected plot in Figure 12-9. 

■ Click on one of these numbers and type a number to replace it. Do the same f
other numbers if you want to change more than one limit.

■ Click outside the graph. Mathcad redraws it using the new axis limits you speci
The corner symbols below the limits you changed disappear. Figure 12-9 show
effect of manually setting limits on a graph.

Figure 12-9: Data limits set manually and automatically. 

Setting default formats

Mathcad uses default settings to format the axes and traces of new graphs you c

Copying defaults from an existing graph

One way to create a new set of defaults is to use the format settings of an existing g
The advantage of this method is that you can actually see how the format settings
as you define them.

To use the format of a particular graph as the default graph format:   
246  Chapter 12  2D Plots
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■ Double-click the graph, or click in the 
graph and choose Graph⇒X-Y Plot  
(or Graph⇒Polar Plot) from the For-
mat menu. Mathcad displays the dia-
log box for formatting a selected graph. 

■ Click the Defaults tab to see the De-
faults page. 

■ Check Use for Defaults. When you 
click “OK,” to close the dialog box, 
Mathcad saves these settings as your 
default settings.

 

Setting defaults without using a graph

You can use the Setting Default Formats dialog box to change default plot setting
set defaults this way:

■ Make sure that you don’t have any graphs selected.

■ Choose Graph⇒X-Y Plot  (or Graph⇒Polar Plot) from the Format menu. You’ll 
see the Setting Default Formats dialog box. 

■ Change the appropriate settings on the Axes and Traces pages.

■ Click “OK” to accept your changes and close the dialog box.

Modifying your 2D plot’s perspective

Mathcad provides options for manipulating the presentation of your X-Y plot or y
polar plot:

■ You can zoom in on a portion of the plot.

■ You can get the coordinates for any point that was plotted to construct the plo

■ You can get the coordinates for any location within the plot.

Zooming in on a plot 

Mathcad allows you to select a region of a plot and magnify it. To zoom in on a por
of a plot, follow these steps:
Modifying your 2D plot’s perspective 247
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■ Click in the plot and choose Graph⇒Zoom from the 

Format menu, or click  on the Graph toolbar. The 
Zoom dialog box appears. The X-Y plot Zoom dialog 
box is shown to the right. 

■ If necessary, reposition the Zoom dialog box so that 
you can see the entire region of the plot you want to 
zoom.

■ Click the mouse at one corner of the region in the plot you want to magnify.

■ Press and hold down the mouse button and drag the mouse. A dashed selec
outline emerges from the anchor point. The coordinates of the selected regio
listed in the Min and Max text boxes (or the Radius text box of the Polar Plot Zo
dialog box). 

■ When the selection outline just encloses the region you want to magnify, let g
the mouse button. If necessary, click on the selection outline, hold the mouse b
down, and move the outline to another part of the graph.

■ Click “Zoom” to redraw the plot. The axis limits are temporarily set to the 
coordinates specified in the Zoom dialog box. To make these axis limits perma
click “OK.” 

Tip If you’re working with a plot that has already been zoomed, you can restore the original 
appearance of the plot. To do so, click “Full View” in the Zoom dialog box.

Figure 12-10: A zoomed-in region of an X-Y plot.
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Getting a readout of plot coordinates 

To see a readout of plot coordinates of the specific points that make up a trace, fo
these steps:

■ Click in the plot and choose Graph⇒Trace from 

the Format menu, or click  on the Graph tool-
bar. The Trace dialog box appears as in the example 
at right. Check “Track Data Points” if it isn’t al-
ready checked. If necessary, reposition the Trace 
dialog box so that you can see the entire plot.

■ Click and drag the mouse along the trace whose coordinates you want to see
dotted crosshair jumps from one point to the next as you move the pointer alo
the trace.

■ If you release the mouse button, you can use the left and right arrows to mov
the previous and next data points. Use the up and down arrows to select other 

■ As the pointer reaches each point on the trace, Mathcad displays the values o
point in the X-Value and Y-Value boxes (or the Radius and Angle boxes in th
Polar Trace dialog box).

■ The values of the last point selected are shown in the boxes. The crosshair re
until you click outside the plot. 

Tip When Track Data Points is unchecked in the Trace dialog box, you can see a readout of 
coordinates for any location in a graph, not just the data points that created the graph.

Figure 12-11 shows an example of a graph whose coordinates are being read.

Figure 12-11: Reading coordinates from a graph.
Modifying your 2D plot’s perspective 249



 

heet, 

Mathcad Users Guide.book  Page 250  Sunday, August 9, 1998  2:59 PM
To copy and paste a coordinate using the Clipboard:

■ Click “Copy X” or “Copy Y” (or “Copy Radius” or “Copy Angle” in the case of a
polar plot).

■ You can then paste that value into a math or text region in your Mathcad works
into a spreadsheet, or into any other application that allows pasting from the 
Clipboard. 
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